Planner
- Planner User Guide

Alvaro del Castillo

Kurt Maute

Pedro Soria-Rodriguez


Chapter 1. Introduction to Planner

Introduction

Planner is a project management tool that allows the user to manage several aspects of a project, including among others planning of tasks using Gantt charts and allocation of resources. It is released under GPL which means that you can use, modify and release the code at your will.

Planner is being developed by CodeFactory AB and by volunteers from the GNOME community. If you want to help the project please please visit the Planner contribution page.

Why use a project management tool in your project

Since a long time ago, managing software projects has been said to be a very unpredictible process because it was very difficult to calculate the cost, time and resources that a project requires for completion in the creation phase.

With Planner, you can construct a global view of the project, know how many resources you have planned to use, and maintain a schedule that you can review as the project advances.

Also, it is a great tool for communication with your customer, both during the project definition phase, and throughout the project life cycle. It is clear that the initial plan won't be the definitive plan, but you have a first aproximation to show to the client and justifiy the cost and time, the two factors that a customer need to contract a project.

Planner's Role in the Project Management Context

Planner is an excellent tool for managing the project schedule and resources, but in order to manage projects consistently and successfully, its important to realize that Planner is a tool that should be used as part of a Project Management Methodology.

A Project Management Methodology is simply a set of detailed processes that define the project life cycle. They normally include three or more phases, with one or more deliverables due at the end of each phase. The final step of a phase is sometimes referred to as a gate, the idea being that the deliverables or requirements of the phase must be satisfied before that phase can officially be considered complete.

Planner, of course, is not a process, methodology, or life cycle. It's a tool that exists to support the process of managing a project, with the goal of delivering the goods on time and within budget. The purpose of this slight digression is to provide the context that Planner should be used in. Below is a high level outline of what a PM Methodology might look like, and where Planner fits in.

  1. Initiation:

    • Performing a Feasability Study

    • ROI (Return on Investment) Analysis

    • Opportunity Review (resulting in a Go/No Go decision)

    • Project Charter

    Use of Planner during this project phase should be limited to identifying major deliverables, high level requirements, and major project milestones. Planner can be very helpful in determining high level estimates of project duration and resources required to produce each deliverable.

  2. Planning:

    • Requirements

    • WBS Decomposition

    • Allocation & Scheduling

    This is the phase where the majority of work will involve Planner. Once the requirements of the project are documented, they should be converted into a Work Breakdown Structure (WBS), which is a deliverables oriented list of tasks that ultimately defines the scope of the project. For instance, one of your deliverables may be to install a new application server. The task 'New Application Server' can be broken down into more detailed steps including design, vendor selection, budget approval, purchase, receipt, and installation. The 'New Application Server' is the deliverable, and the other tasks support that deliverable by breaking it down into chunks that are small enough to assign to different people, but large enough that we're not "micro-managing". The project manager can then use Planner to assign the tasks to individuals, and schedule them appropriately.

  3. Execution:

    • Tracking & Corrective Action

    • Testing

    • Product Delivery

    In the execution phase, the project manager's role is to monitor progress against the schedule, and initiate corrective action in the event of a schedule or budgetary slip. Progress against tasks is measured in Planner by periodically updating the % complete field on each task. The project schedule must also be updated to reflect changes in the plan and corrective actions taken.

  4. Closure:

    • Customer Acceptance

    • Lessons Learned

    Lessons learned and other closure activities should include a final review and update of the historical information in Planner. This activity is useful in that the historical information from the current project can be leveraged in future projects to make project planning and estimating faster and more accurate.

Chapter 2. Using Planner

Main project window

Starting a new project

Upon starting Planner a blank screen is presented, ready to begin working on a new project. You may also choose the option "New Project" from the "File" menu, or press the short-cut key combination "CTRL-N". A third option is to use the icon labeled "New" from the toolbar to create a new project. Figure 2.1 shows the first screen you will find when Planner starts.

Figure 2.1. New project window

More than one project may be open at the same time. Each project will have its own Planner window. Try it by pressing "CTRL-N" several times. You should get something similar to Figure 2.2.

Figure 2.2. Several projects at the same time

Project Views

There are several screen layouts in Planner (called views). Views are helpful in managing the various aspects of a project. For instance, the Gantt Chart view displays the project tasks, while the Resources view shows the resources that may be asigned to each task. The Tasks view simply shows the tasks without the Gantt Chart on the right hand side. Each of the views can be selected by clicking the appropriate icon on the vertical toolbar on the left hand side of the Mrproject window.

When a new project is created, the first screen the user sees is the Gantt Chart for the new project. A Gantt chart is a graphical display of all the tasks that a project is composed of. For each task there is a graphical representation of the length of time it is planned to take. Use the "Insert task" icon from the toolbar on this screen to enter tasks for the new project. In the Gantt view, you may specify a name, a duration, and the amount of work effort required to complete the task. The difference between duration and work effort is that duration is the amount of calendar time allocated, whereas work effort is the amount of actual time it takes to complete the task (i.e. you have 3 days (duration) to write a letter, but it only takes on hour (work effort) to actually do it. All durations are entered in days, with fractions permitted (i.e. 3.4 days).

Figure 2.3. Planner Gantt View

The left toolbar includes the "Tasks" icon. Click on it to display the Task view. Tasks are also shown on the Gantt view, but the Task view shows the task name, start date, finish date, and duration.

Figure 2.4. Planner Task View

The left toolbar also includes the "Resources" icon. Click on it to display the Resources view, in which you can manage the resources of the project (adding and removing resources). Resources can also be grouped.

Figure 2.5. Planner Resource View

Project properties

Under the "File" menu there is an option to display the project properties. In this dialog box you can edit the name of the project, its start date, the name of the project manager and the organization the project belongs to. Its important to note that the default start date for all tasks is the project start date. Therefore, its important to set the project start date before entering many tasks. In the event that you do change the project start date after tasks have been entered, they will default to the new start date, unless they're associated with a constraint, such as a predecessor task or "start no earlier than" constraint.

Figure 2.6. Planner Project properties

Load and save projects

From the "File" menu you may save your current project. Choose the "Save As" option to save it under a different name than the current name. A "Save" icon can also be found on the toolbar.

You may also load a project previously saved with Planner by choosing the "Open" option from the "File" menu, or by clicking on the "Open" icon from the toolbar.

Working with tasks

Task properties

Some task properties can be edited directly from the Gantt tasks view: the name for the task, the task duration in days and the work effort. You can also launch the task properties dialog from here by right clicking on a task and choosing 'Edit task'.

Figure 2.7. Gantt View

In version 0.5.92 we recover the Task View. In this view you can edit more fields for a task than in the Gantt View, and is the preferred view when you start to add tasks to a project.

Figure 2.8. Task View

For editing all the task properties, you can press the right mouse button over a task and select Edit task from the dialog that appears. Alternatively, you can select the task and use the main menu editor Edit option. Once you have the task properties dialog, you have several tabs to modifiy the properties.

  • Figure 2.9. Task properties dialog

    In the general tab you can edit the task name and duration which you can also change directly from the task list. Additionally, you can track the percentage of completion and assign a priority to the task.

  • Figure 2.10. Task resources dialog

    Here you can change the resources assigned to a task. In this example you can see the four different resources available, and if for example, you need a project manager for this task, you only need to check the box for this resource. The Gantt view will show the resources assigned to a task to the right of the bar.

    Figure 2.11. A resource has been assigned to a task

  • You can see in the predecessors tab the tasks that need to be finished before the task being edited can start. In this example, we have three tasks. In Figure 2.12, the third task, t3, requires that t2 be complete before it can start.

    Figure 2.12. Task predecessors dialog

    From this dialog, you can change the task predecessor, the predecessor type, and edit the lag between the task and the predecessor. Also, you can add and remove predecessors from this dialog by clicking the Add or Remove button.

    Figure 2.13. Add/Remove predecessors dialog

    When you add a new predecessor you need to choose the task predecessor, which you can select from the dropdown list box. The next field is the Relationship type. You can choose Finish to Start (FS), Finish to Finish (FF), Start to Start (SS), or Start to Finish (SF). Finally, you can enter a lag time for the relationship, which represents the number of days after the relationship has been satisfied. For example, if you enter a lag time of 1 in a Finish to Start relationship, it means that the current task may begin 1 day after the predecessor task has completed.

    Figure 2.14. Add predecessors dialog

  • You can add notes to the task using the editor in the Notes tab. You can also insert the current time to the note using the button that appears in the dialog.

    Figure 2.15. Task notes dialog

  • The last tab from the task dialog editor is the Advanced tab. Currently it isn't implemented, but here you will find additional propeties that will be added in future releases.

    Figure 2.16. Task adavanced properties dialog

Creating subtasks

Complex tasks can be broken down into subtasks to make them easier to Manage. A task that is divided in subtasks is called a summary task. The summary task's start date and the duration can't be edited because it calculated from the subtasks.

Figure 2.17. A Task with subtasks

Task dependencies

Another way of looking at predecessors.

To start a task, you often have to finish other tasks first. This can either be set up by using the predecessors tab in the task edit dialog as shown above, or it can be done graphically by using the Gantt chart. If you click on the bar that represents the predecessor (and hold down the mouse button), an arrow appears. dragging that arrow onto the bar that represents the dependent task will create the dependency. The Gantt chart will immediately reflect the new relationship by shifting the dependent task to start when the predecessor is scheduled to complete. By creating a dependent relationship this way, Planner always assumes a Finish Start relationship with zero lag time. You can modify this relationship by opening the task edit dialog of the dependent task, and selecting the predecessors tab.

Figure 2.18. Creating a task dependency

Figure 2.19. A dependency has been created

If you want to remove the dependency, you can select either of the two tasks and delete the link by clicking the unlink icon on the toolbar, or by right clicking either task and selecting unlink from the popup.

Moving tasks

If you need to rearrange the order that tasks are displayed in the task view, you can do so by selecting the task you want to move, and utilizing the Move Up and Move Down buttons on the toolbar.

Figure 2.20. Moving task up and down

Zooming in the Gantt View

The tasks in a project can have very different durations and sometimes you need to have a close view of the timeline to see the details of some task dependencies, but other times you need a higher level view of the whole project. To support both needs, Planner has a powerful zoom system that lets you zoom to fit the complete project, zoom in the view or zoom out incrementally to whatever size you like (hours being the lower limit, and years is the upper limit).

Normally the best way to start seeing a project is with the zoom to fit.

Figure 2.21. Zoom to fit the project

Then you can play with the zoom in and zoom out buttons to select the timeline zone in which you want to work.

Figure 2.22. Zoom in a zone of the project

Task constraints

All tasks begin on the project start date by default (as shown by the constraint type "As soon as possible" in Figure 2.23). One exception is the case where a dependency is set up. There are times, however, that a dependency doesn't exist, but the task must start on, or no earlier than a specific date. You can specify these constraints in the start date dialog editor.

Figure 2.23. Task constraints

You can delete the constraints for a task using the menu Edit entry and removing the constraints for the current task or for all the tasks.

Working with resources

Resources properties

Currently (version 0.5.9) the resources in Planner have the properties:

  • Name: the resource name

  • Group: the group that the resource is assigned.

  • Type: Currently available types are Work and Material. Work is for human resources working in the project, and Material is for non-human resources required to complete the project.

  • Email: the electronic mail to contact this resource. It will be used as the communications system with the resources.

  • Units: how many units are available for this resources to be used in the project.

  • Rate standard: the resource cost when it is used in a normal way.

  • Rate overrated: the resource cost when it is overused. This could be cost for overtime pay or other cost incurred when people work extra be cost for overtime pay or other cost incurred when people work extra hours in a project.

Currently only name, group, type, and email are available, but the others will become available in future versions.

Figure 2.24. Resources View

As with the columns from other Planner views, you can sort the columns by clicking on the column name. The following figure is an example of the resource view sorted by the name column.

Figure 2.25. Sorting in the resources editor

Group editor

With the group editor you can define groups to be used to classify your resources. A group has a name, a manager, telephone, email, and finally, an option to specify the default group. If you specify a default group, every new resource that you add will placed in this group. Of course, you can still change the group to another if necessary.

Figure 2.26. Group editor

Appendix A. Planner Community

As any free software project, Planner has a nice community around it. You can find them in several places:

  • Planner web page: this is the first source for things related with Planner Link to Planner web page

  • Planner user mailing list is the place to ask general question about Planner. You will find there a group of people that can help with your questions and problems. Link to Planner general mailing list

  • You have also and IRC channel in the GNOME IRC server in irc.gnome.org. The channel name is #mrproject and the Planner developers are usually there.

  • Planner developer mailing list is the place to find the Planner developers and ask them question about the Planner development. Link to Planner developer mailing list

  • If you want to know the day to day changes in the Planner live you can subscribe to the Planner cvs commit list. Every change in the Mrproject code base is announced in this list. Be careful because this list is a high traffic list because Planner developers are hard working guys ;-) Link to Planner cvs mailing list

Appendix B. Project Management Web Resources

The PMI Web Site

Bibliography

[PMBOK] Project Management Institute. Copyright 2000 Project Management Institute, Inc.. 1-880410-23-0. Project Management Institute, Inc.. A Guide to the Project Management Body of Knowledge (PMBOK Guide).